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I. Introductions

1. PCMMC Package Contents

2. PCMMC Installation


2-1. Requirements


2-2. Procedures

3. Running Option

1. PCMMC Package Contents

Setup Diskettes: 11 3.5 inch floppies or 1 CD

Users’ Manual: 1 copy

2. PCMMC Installation

2-1 Requirements
Items
Specifications
Etc.

PC
Recommanded Pentium PC or above


Main Menory
Recommanded 32MB or above


Hard Disk
40MB at minimun


Modem
1200 ~ 38400 baud


OS
Microsoft Windows 95® or above




        <Table 1.1. Installation Requirements>

During PCMMC running all the other application programs should be closed for better performance

2-2 Procedures

1. At your PC where the Microsoft Windows 95 or Microsoft Windows 98 is booted, insert the 1st setup diskette or PCMMC setup CD into drives and run setup.exe.

2. At first, appears ‘Welcome’ screen. And you can do setup using ‘Next’ button easily. 

-. Setup Type

      If you select ‘Normal’, setup program copies common files of PCMMC 

      including PcmmcWin.exe, all of DB files, ect.. Otherwise, you copy 

      files want to.

    -. Select ODBC Driver

      You must select one ODBC driver. You can select one of Access, 

      Foxpro, Dbase, Paradox.

< notes >

1. If you want to exchange ODBC driver, you must end PCMMC. And you can exchange driver at ODBC applet in control panel.

2. Change an inserted diskette with the appropriate one when you see a message such as ‘Insert a diskette numbered #’.

 3. Running PCMMC

It’s time to run the PCMMC program if you installed it successfully.

1. Double-click the PcmmcWin.exe in the folder you installed using the Windows Explorer or you can find a shortcut ‘PCMMC for Windows’ for it in the start menu.

2. There are 2 running options according to its link to the DCS400si Key Telephone System, on line and off line. You can select one at Running Option (Fig 1-1). 

3. At Running Option if you press button beside off line, you can see <Fig 1-3 Open a database file> and select a file you want to. If you press button beside on line, it is connected to <Fig 2-32 Communication setting>.

4.  Quickstart uses only offline mode. If you select quickstart, operated PCMMC without file open.
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<Fig. 1-1 Running Options >
CASE: On Line

5. The on-line means that it is really connected to the DCS400si Key Telephone System. The PCMMC checks first if both its version and KSU’s matches and displays a warning message if they are different.

6. [image: image3.png]


The following message box appears if both versions are same. 


<Fig. 1-2 Confirmation for Technical Passcode of DCS II connected(Online) >

7. Input the technical passcode for DCS400si system connected and the PCMMC starts to load down a few necessary data such as ‘card configuration’ and dial number plan’. 

8. The PCMMC exits automatically if you enter the discorrect passcode 3 or more times.

CASE: Off Line

5. There displays a dialog box where a Database file(*.DCS) must be made a choice. You must create a one when no database files are like the very first execution after installation. And you can see DATABASE Version, Country, Last updated date of a selected database file at DCS information.
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  < Fig. 1-3 Open a Database File >

6. When you select KeyPhone DB or create new one, a screen such as Figure 1-2 shows up and asks you Technical Passcode(Offline) as it did in on-line mode.

  7. At this time, check version of DB as you did in on-line mode.

Find the version of Sheet Info is the same as that of DB you downloaded before, the program starts to run without changing DB.

If the DB version of Sheet Info is older than that of DCS DB, it displays message to change Sheet Info DB. If the version is later, it checks if the DB is changed. The contents of change are shown in Table 2-1.

Changed Parts
Changed Content

Table is missing
Table will be deleted. 

Table is newly made
Table will be generated.

Table is changed
If any field of Table is added, deleted or changed, new table will be generated and records will be allocated.




<Table 2-1 DBChanged Content>

3. When you select KeyPhone DB or created new one, a screen such as Figure 1-2 shows up and ask you Technical Passcode as it did in on-line mode. If the Passcode is correct, the main screen shows up.

4. If you fail to enter Technical Passcode 3 times, the program exits automatically.

II.PCMMC Menu

1. Start Screen

2. File Menu

3. Edit Menu

4. Sheet(Edit:View) Menu

5. Load Menu

6. Option Menu

7. Window Menu

8. Help 

1. [image: image5.png]


Start Screen

 <Fig. 2-1. Main Screen>

The Figure 2-1 shows the main screen. You can do everything about PCMMC in this screen. You have to finish one MMC or menu before you start another.

MMC menu is able to make multi windows.

You can click icons to do functions you frequently use during PCMMC and the Status Bar at the bottom of the main screen shows the operation status of each window. PCMMC Menu is made treeview for open MMC more easy. The current mode and the name of KeyPhone DB are always displayed. <fig 2-1>s is ONLINE mode screen.
2. Start Menu
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2-1 File 




   <Fig. 2-2. File Menu Screen >

When open file is changed or when mode is changed to on-line, if there is any changed data in every sheet window currently open, the program asks for confirmation and continues to close current file. You can’t open file in on-line mode.

The file menu consists of menus such as New, Open, Close, Save, Save As, Print, Set Items on/off to print, Database Information, Exit as shown in Fig. 2-2

The last entry in File menu, ‘C:\Program Files\PCMMC for DCS400si \DCS\t1009.dcs,’ indicates the file currently open only in off-line mode. 

NEW

This menu is used only in off-line mode. 

When new file is generated, the program asks user to save currently used file and exits.

When you select new file(New) from File menu, a screen as Fig. 2-3 shows up. Enter Passcode to assign to newly generated KeyPhone DB. Select country version on Country and press OK. A screen as Fig. 2-3 shows up. And comfirm the newly passcode.
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Select new file and press Open to create new file. If you select using KeyPhone DB now, the file will not overwrite. However, the current file will be overwritten if you select different KeyPhone DB, so you should be careful.

You can do same thing as new file(NEW) when you click icon as above.
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     <Fig. 2-3. Options for New File >
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<Fig. 2-4. Input New file name >

Open 

You can use this menu only in off-line mode.

If you check ‘Show DCS File Information’ at file open dialogbox, you can see database version, country, last updated date of selected file.

Input or double-click file name you wan to work on.

The screen shown in Fig.1-2 shows up again to ask Passcode when you input file name. An error message is displayed and the open menu is cancelled if you fail to input correct Passcode for 3 times.

If the file name is new one, the program creates the new file. 
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You can do same thing as open file(OPEN) when you click icon as above.
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<Fig. 2-5. File Open Screen>

Close 

You can use this menu only in off-line mode.

This menu will exit active database in the program.

Save 

You can use this menu only in off-line mode.
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This menu will work only for Sheet windows that are currently active in the program with changed data. 

You can do same thing as Save (Save) when you click icon as above.

Save As…
You can use this menu only in off-line mode.

When you select ‘Save As…’ from File menu, the screen shown as Fig. 2-7 shows up and change the file name of currently working file with new file name. If you input existing file name, you can overwrite the file if it is not currently used.
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     <Fig. 2-6. Screen to save with new name >

Print 

You can use this menu only in off-line mode.

When you select Print from File menu, the selected item in Set Items on/off to Print (will be described later) will be printed.
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If you select the above icon, only currently active MMC will be printed, unlike you select print item in the File menu.
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Set Items on/off to Print

You can use this menu only in off-line mode.




<Fig. 2-7. Set Items on/off to Print >

When you select Set Items on/off to Print from File menu, the screen shown as Fig. 2-8 shows up. This screen lets you to select items to print when you want to print several items at one time. 

Select Print field for items to print. 

Select Tenants to print on Tenant 1 and Tenant 2 fields and select Cabinets to print on Cabinet1 and Cabinet 2. 

When you select Print check field, it selects Print of all selected MMC fields that are selected from MMC Kinds. Tenant 1 check box does the same thing as Print check box.

You can select MMC by its functions in MMC Kinds field.

Database Information 
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You can use this menu only in off-line mode.



     <Fig. 2-8. Information Screen >

This screen shows several information about currently open file.

The location of currently open file, DB version, country version and the last update time are displayed.
Exit 

Select Exit from File menu to finish work and terminate program. If changed data in open file is not saved or updated, the program confirms this and terminated.
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2-2. Edit 




<Fig. 2-9. Edit Menu (Edit) Screen>

You can use Edit menu to change any data in each Sheet window. All of these functions are supported by pop-up menu in each Sheet window. You can not select any of Edit menu if there is no Sheet window open.

Undo

You can use this menu to cancel the last edit operation or data input.
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Every time you click this, the program reverts to the previous state. You can cancel up to 10 times. You can not select this menu after you have cancelled 10 times.

You can do same thing as Canceling (Undo) when you click icon as above.

Redo
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You can use this menu to do the operation again that you have canceled.

You can do same thing as Do the cancelled Operation(Redo) when you click icon as above.
Cut 
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You can select and remove selected data to paste into another location.

You can do same thing as Cut when you click icon as above.

Copy 

You can use this menu to copy selected data for duplication.
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This is different from Cut that Cut removes the data from screen but Copy leaves the data on the screen for duplication.

You can do same thing as Copy when you click icon as above.

Paste 

You can use this menu to paste data that you have cut or copied.
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If field type of data that you copy or cut is different, does not paste. 

You can do same thing as Paste when you click icon as above.

Delete

Unlike Cut, you can use this menu to delete data from screen. That is, the screen will display initial value.

Fine

You can use this menu to find a data you are looking for. If the data is not found in selected area, the program searches the whole open Sheet windows.
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You can select Up to search to upward and Down to search downward from Direction.




 <Fig. 2-10. Find Screen>

Replace

You can use this menu to change data in To with that in From within selected area. If you do not specify any area, the program will find and replace data in the whole Sheet window.

You can select Up to search and replace to upward and Down to search and replace downward from Direction.
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 <Fig. 2-11. Replace Screen>

Add / Remove Record
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You can use this menu to add data read from DB or downloaded from System into currently active MMC. And you can use this menu to remove data from currently active Sheet window.



<Fig. 2-12. Add and Remove Record Screen>

You can add each data or all data or selected data at once. And you can remove each data or all data or selected data at once. 

If you want to remove data, you have two options.

‘Remove only Screen’ means clear data only on screen remaining DB, ‘Remove DB’ means clear data not only on screen but also on DB in off line mode. In Online mode ‘Remove only Screen’ is the same function as in Off line mode, but ‘Remove DB’ means clears data on screen and on DB of DCS400si Keyphone.

For your information, it is more convenient to click right mouse (PS/2) button on the grid of MMC and add data from pop-up menu.

Specific MMC(AA Translation, Acount Code, Authorization Code, CID Translation, Cost Dial Plan, DID Digit, LCR Digit, Toll Table, System Speed Dial) is able to add all in add/remove record on online mode. If data does exist, you can use add in add/remove record.

Upload 

You can use this menu only in on-line mode. 

After you modify the downloaded data in on-line mode and select Upload, the program sends the data to the System.
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2-3. MMC Fields (Sheet(Edit/View))

 

<Fig. 2-13. MMC Menu(by the functions) Screen>
Menu Display 

You can categorize the menu by its functions/KMMC (You can select this from Options/Display(Sheet Edit/View) menu).

If you categorize the menu by its functions, it can be categorized into 5 categories such as Station, Trunk, Common, System and Group. If you categorize the menu by KMMC, it can be categorized by its numbers such as 100, 200, 300, 400, … , 600, 700, 800, and Others… as shown in Fig. 2-14.

MMC menus are categorized by the functions as default.

Mode change by the MMC menus is impossible.

Easy Data Input

The program is designed to make data input to each MMC easy. 

Combo Box is used not only for common selection but also for telephone number entry, so you can easily input data. Also, it is easy to input data by typing. You can use Spin button to easily input numbers.

Independence of Each Sheet Window
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When you select one MMC Sheet from Station, Trunk or any other function, different window is open according to each function. You can open up to 10 Sheet windows simultaneously except for all of windows without Sheet windows.



 <Fig. 2-14 MMC Memu(by KMMCs) Screen>

Menus that You can Use

You can use all of Edit and Load menus and some of File menus. You can use the following menus from File menu.

Menus you can use
Description

Save
Saves all MMC contents that are open.

Print Icon
Prints the screen information of currently active MMC

 

    <Table 2-2 . Menus you can use by the MMC Menus >
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if you click print icon, you can see preview screen. You can do selection of printer, orient, zoom in print or preview.




< fig. 2-15 Preview Print Window>
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Online Menu ( Halt / Restart )


   <a. Halt Screen>


   <b. Restart Screen>




<flg. 2-16 Online Menu Screen>

Halt is the function that pause functions of each slot or each cabinet.

Restart is two way. One is what restart system without memory clear, the other is what restart system with memory clear. What restart system with memory clear loses all of data on keyphone system.
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2-4. Load 




<Fig. 2-17. Load Screen>
The Load menu consists of menu that you can send/receive data and menu that you can select MMC to be transmitted such as mode change, setup and run of download/upload, remote MMC.
Mode 

If you select mode at online mode, PCMMC exchanges for offline mode. And if you select mode at offline mode, PCMMC exchanges for online mode. You can see details as following <table 2-3>

On-line Mode

(to offline mode)
This connects to system and downloads DB from system and upload inquired/edited and updated DB to system. 

You can toggle the Mode menu to change to off-line mode. If you transit to off-line mode, you can do your work by selecting KeyPhone DB from File -> Open menu.

Off-line Mode

(to online mode)
You can read and inquire/edit KeyPhone DB(dcs file). 

You can toggle the mode menu to change to on-line mode.

When you transit to on-line mode, it checks Technical Passcode of System and receives data from Config Card and Number Plan. You can not transit to on-line mode if you fail to enter correct Technical Passcode and returns to off-line mode.




<Table  2-3. Mode Change>

Download 

This function backups DB of the system to your PC.

At first you select file that will be downloaded at screen like fig.2-18. If line mode is offline mode, you can select current using database.

You can select MMC to download from Set Items On/Off to load Transmission Menu 
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<Fig.2-18. Download Screen>
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<Fig. 2-19. File Selection Screen >

Upload Config Card and Number Plan at first because Config Card and Number Plan have an effect on all of MMC, whatever you select among MMC items.

Upload 

You can use this menu to transmit KeyPhone DB to System.

At first you select file that will be downloaded at screen like fig.2-18. If line mode is offline mode, you can select current using database.

You can select MMC to upload from Set Items On/Off to load Transmission Menu 
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<Fig. 2-20. Upload Screen >

The one thing you should be careful is that the data of System Configuration Card should be the same as that of System. Check the configurations of card and port before you upload the data.

Upload Config Card and Number Plan at first because Config Card and Number Plan have an effect on all of MMC, whatever you select among MMC items. And uploading order may exchange on several MMC. You can see details as following <table 2-4>

MMC group
Related MMC
Details

Key Program
Station Key Program

System Key Program
If you select Both Station Key Program and System Key Program, System Key Program is uploaded at first and Station Key Program at next time because of System Key Program overwrites all of Station Key Program for each port.

Speed Block

& Dial
Station Speed Dial

System Speed Dial

Station Speed Block
If you select Station Speed Dial or System Speed Dial, Speed Block is selected automatically. And Speed Block is uploaded before Station Speed Dial and System Speed Dial..

Station Group
Station Group
If you select Station Group, upload before all of MMC except for Config Card and Number Plan.



    <Table. 2-4. Several MMC Uploading Order Changes >
Remote MMC 

You can use this menu to remotely control DB by using modem.

When you select Remote MMC menu, then a file selection screen shows up. 
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<Fig. 2-21. Remote MMC Screen>

You can input up to 21 characters including numbers and letters in the Name field. Telephone Number field can hold up to 21 digits of telephone number. Buttons are configured as Arrange, Add, Remove, Save, Find, Connect, Disconnect, and Exit. 

<Button Description>

Button Name
Description

Add
You can add new data (name and telephone number).

Remove
You can click the name you want to delete and click Delete to remove the data.

Save
You can select and run this menu only when you have any data changed. 

Find
This menu does the same function as Find form Edit menu.

Connect

Disconnect
This menu dials to the phone number. The status is displayed at the bottom of screen. This box shows the connecting time etc.. 

If you press Cancel button during dialing, dialing stops 

Exit
It asks you if you want to save and exit from Remote MMC screen.

Edit menus and File menus such as Cut, Copy, Paste, Remove, Save, Find, and Exit are also used in Remote MMC menu.

Set Items on/off to load
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 You can select MMC items that you want to download or upload in this menu .



      < Fig. 2-22. Screen for Set Items on/off to load >

Select Load field to check whether to transmit. Select Tenants to load on Tenant 1 and Tenant 2 fields and select Cabinets to load on Cabinet1 and Cabinet 2. 
You can select MMC by its functions in MMC Kinds field.

When you select Load check field, it selects Load of all selected MMC fields that are selected from MMC Kinds. Tenant 1 check box does the same thing as Load check box.

And if you select Station Speed Dial or System Speed dial, Speed Block is selected automatically.
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Options 



  < Fig. 2-23. Options Screen >

You can select language and display for screen including each MMC from Option menu. You can also select display mode for MMC Menu and setup for transmission specification for including modem.
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Option : General



     < Fig 2-24. General >

This menu is used to choose MMC menu display type, select display language  and set parameters for error messages. 

Choose MMC menu display type : 

you can select one of Function and KMMC.If you select a ‘Function’, Edit/View menu display MMC items in the shape if Station/Trunk/Common/System/Group/Online,

In case of ‘KMMC’ Edit/View menu display MMC items in order of KMMC 100~900.

Choose Langauage :

This is used to set language displayed at screen  Primary is English and secondary is defined by users(Korean, German,French etc).

Choose Error type:

This is used only Online mode. If error occurs, set the one option; display immediately or display after finishing proceeding job. And you can choose the maximum number of error message at one time.
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Option : Sheet Color



        <Fig. 2-25. Sheet Color>

This menu is used to set the color of Grid tools. You can set not only Forecolor , backcolor but also alternative color for making more distinction columns.
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Option : Link Type




 <Fig.2-26 Link Type>

This menu is used to set  the options for communication between PC and System.

LINK KIND

It has two kinds : Local/Remote and Direct/SIM

If you want to connect directly using  1,2,5 and 6 SIO port(MMC804 system I/O mode), select Local and Direct.

If you want to connect via SIM using 3,4 SIO port, select Local and SIM.

Else if you want to connect at remote site via modem, you select Remote Direct or Remote SIM.

COMMUNICATION

It set the communication parameter – serial port, baud rate, data bit, stop bit and parity.
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Option : Time Setting



          <Fig. 2-27. Time Setting >

This menu is used to set the several timers for ONLINE mode.

TIMERS FOR MODEM

It’s necessary to connect to system via modem. : set the redial time and redial count when connectin fails.


Counts to Re-Dial :
 Default value is 5counts.




   
 Avaialbe value is from 1 to 9.


Secounds to Re-Dial :
 Default value is 50seconds.




   
 Avaialbe value is from 1 to 99sec.

TIMERS FOR MESSAGE

At online mode, When System has no response that  required a message by PCMMC you can set the re-requst counts and re-requst timers. And you can set also the waiting timer for response when system doesn’t send responses.


Counts to Re-Request : 
Default value is 5counts.




   
Avaialbe value is from 1 to 9.


Seconds to Re-Request : 
Default value is 5seconds.




   
Avaialbe value is from 1 to 9seconds.


Seconds to Wait Response : Default value is 50seconds.




   
Avaialbe value is from 1 to 99seconds.

LINKALIVE

If PCMMC want to be continued a Online mode, it exchange periodic message with system each other.

So this item is set to the interval timer ans retry counts.    


Retry Count: 

Default value is 1count.




   
Avaialbe value is from 1 to 9.


Interval Timer : 

Default value is 3seconds.




   
Avaialbe value is from 1 to 99seconds.

2-5. Diagnostics / Alarm
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< Fig. 2-28. Options Screen >

This menu is MMC of Diagnostics, Alarm, Super MMC and can use only online mode. All of MMC of  this menu do same thing as MMC sheet of Sheet(Edit/View) Menu.

CCP/ECP Restart History (KMMC : 997)

Description

This MMC displays previous histories for system restart. There are some buffers to be written some valuable informations for later debugging purposes when the KSU restarts, and whenever it occurs one of the six chunks of buffers is filled with the time, reason, SR(Status Register), PC(Program Counter), ISP(Supervisor's Stack Pointer), USP(User's Stack Pointer), etc. Another information to be written is the reason why it occurred such as ADDRESS ERROR, OS ENDLESS LOOP, ILLEGAL OP CODE, ZERO DIVIDE, PRIVILEGE VIOLATION, WRITE PROTECTION, DUMMY, KMMC MEMORY CLEAR, KMMC RESTART.

This MMC is read-only.
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Feature (1)

Feature (2): ISP Data, USP Data
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Related MMC


MMC 997: RESTART HISTORY

Field by Field Attribute

Field Name
Description
Initial Value

CCP/ECP
Restart History for  CCP or ECP; 1[CCP], 2[ECP]
-

INDEX
Index for Restart History Stack; from 1 to 5
-

TIME
Time data for Restart; YYYY/MM/DD HH:MM:SS
-

REASON
Reason for Restart; 

1 for ADDRESS ERROR

2 for OS ENDLESS LOOP

3 for ILLEGAL OP CODE

4 for ZERO DIVIDE

5 for PRIVILEGE VIOLATION

6 for WRITE PROTECTION

7 for KMMC/PCMMC MEMORY CLEAR, RESTART

8 for DUMMY
-

MODE
CPU's Running Mode; 1[Supervisor], 2[User]


TASK ID
Running TASK's ID when the Restart occurs ;

0 for INITIAL & CONFIG task

1 for ERROR HANDLER task

2 for NON-PREEMPTIVE PERIODIC task

3 for MESSAGE HANDLER task

4 for DIAGNOSTICS task

5 for DATA CALL task

6 for CALL task

7 for PREEMPTIVE PERIODIC task

8 for SMDR task

9 for PCMMC task

10 for IDLE task


SR
Values for Status Register of M68302; 4 bytes long
-

PC
Values for  Program Counter of M68302; 4 bytes long
-

ISP
Values for Supervisor's Stack Pointers; 4 bytes long
-

USP
Values for User's Stack Pointers; 4 bytes long
-

D0
Values for 1st DATA Register; 4 bytes long
-

D1
Values for 2nd DATA Register; 4 bytes long
-

D2
Values for 3rd DATA Register; 4 bytes long
-

D3
Values for 4th DATA Register; 4 bytes long
-

D4
Values for 5th DATA Register; 4 bytes long
-

D5
Values for 6th DATA Register; 4 bytes long
-

D6
Values for 7th DATA Register; 4 bytes long
-

D7
Values for 8th DATA Register; 4 bytes long
-

A0
Values for 1st ADDRESS Register; 4 bytes long
-

A1
Values for 2nd ADDRESS Register; 4 bytes long
-

A2
Values for 3rd ADDRESS Register; 4 bytes long
-

A3
Values for 4th ADDRESS Register; 4 bytes long
-

A4
Values for 5th ADDRESS Register; 4 bytes long
-

A5
Values for 6th ADDRESS Register; 4 bytes long
-

A6
Values for 7th ADDRESS Register; 4 bytes long
-

A7
Values for 8th ADDRESS Register; 4 bytes long
-

ISP Data
Values where ISP addresses; 256 bytes long
-

USP Data
Values where USP addresses; 256 bytes long
-

Memory Dump (KMMC : 990, 991, 992)

Description

This MMC dumps the memory areas of CCP/MP, CCP/SP and ECP and then displays them on screen.
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At first start address input as above figure. ‘<<’ or ‘>>’ means page movement. ‘<’ or ‘>’ means line movement. If you click ‘Jump’, appears as above figure.
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Feature

Related MMC


MMC 990: MP Memory Dump


MMC 991: SP Memory Dump


MMC 992: Display Memory

Field by Field Attribute

Field Name
Description
Initial Value

AREA
Area of memory to dump;

1 for CCP

2 for ECP
-

ADDRESS
Address of Memory; 4 bytes long
-

DATA
Value of each byte; 16 rows and 16 bytes in a row
-

Static Database Information

Description

This program lets retrieves some basic informations about each database in KSU system, their start addresses and unit sizes. Another password for this program is needed like in Diagnostics/ Memory Dump.
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Feature 

Related MMC


Diagnostics: Memory Dump

Field by Field Attribute

Field Name
Description
Initial Value

Database Name
One of the KSU/Databases such as SYS_INFO_DB, etc.
-

Start Address
An 8 bytes-long ASCII string for start address of each database.
-

Unit Record Size
Number of bytes of a record
-

Show System Resources (KMMC : 850)

Description

Used to take a "snapshot" of system resources and display number free and number used. This MMC is READ ONLY. 

TimeSlots


DSP's


CID DSP's
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Feature

Related MMC


MMC 850: SHOW SYSTEM RESOURCES

Field by Field Attribute

Field Name
Description
Initial Value

TIMESLOT
Number of Timeslots free and used
-

DSP
Number of DSP Channels free and used
-

CID DSP
Number of CID DSP Channels free and used
-

System Alarm Report (KMMC : 851)

Description

Used to view system fault alarms. Alarms must be retained in the alarm buffer for Alarm Reporting. The alarm buffer will hold up to 50 Major and 50 Minor alarms on a first in - first out(FIFO) basis. The CLEAR option clears the alarm memory of all existing alarm data. Alarms automatically print to the SMDR port(if so uquipped). If the alarm buffer is cleared only new fault alarms will appear in the alarm buffer. 

View alarms


Clear alarm buffer

Clear print buffer
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Feature (1)
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Feature (2)
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Feature (3)

Related MMC


MMC 851: SYSTEM ALARM REPORT

Field by Field Attribute

Field Name
Description
Initial Value

Index
Alarm Buffer's Index
-

Time
Clock Data when Alarm occurred
-

Alarm Code
One of Alarm Codes major and minor
-

Port Number
Fault Position for the Alarm according to Alarm Code,

Cabinet Number

Slot Number

Serial Port Number
-

Status
Error Values for the Alarm,

GOOD

BAD
-

Clear Alarm…
Clear Print…
One of following 2 Commands,

Yes for Clear Buffer Now

No for Don't Clear Buffer
No
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 2-6. Window



        <Fig 2-29. Window Screen >
Menus

Menu
Description

Cascade
Arrange open windows one on top of another

The Horizontally
Arrange open windows horizontally

The Vertically
Arrange open windows vertically

Arrange Icons
Arrange as icons

Close All
Check if user wants to save the data and close all open windows.




<Table 2-5. Windows Menu>

As shown in Fig. 2-29, the currently open windows are listed. You can click the window active. Check mark(V) appears on that window.

2-7. Help

You can press F1 where you want help, then explanation about the corresponding functions and terms are displayed. There is another detailed description about MMC. Also related MMC are listed so you can select corresponding MMC to edit.

Contents & Index
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   <Fig. 2-30  About PCMMC Screen>

Content describes how-tos and functions of PCMMC by its subject.

You can use keywords or keyMMC No. to find corresponding function in index.

AutoInstallation

This function help using MMC at adding or removing card on Keyphone System.

About PCMMC
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When you select About PCMMC, a screen shown in Fig. 2-37 appears. This screen shows what kind of program the user currently uses.



   <Fig. 2-31 About PCMMC Screen>

Press System Info button to see detailed specification of current system.

III. MMC Items

1. STATION MENUS

2. TRUNK MENUS

3. COMMON MENUS

4. SYSTEM MENUS

5. GROUP MENUS
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